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Me, selwan ag kupi efmae, tiawi 1itraus
traus traus traus, natrauswen ga 1itaos

nlag. Itrausi pan kaipa. Me komam uta laap
kin uto mau, a? Malen umat, 1inom.

But when you are far away the old man can
talk and talk and talk, his story i1s like
the wind. He tells 1t and 1t is gone. But

there aren't many of us left. When we die,
It will be finished.

(NT1-98009-A, 1932.36 1942.10)
\\ tKalfapun Mailei, 1998, Erakor Village, Efate, Vanuatu



Elan

Transcribe media
Multiple video files

Provides a time-aligned transcript of the media
— Index of the media
— Useful for subtitling

Slow down playback
Automatic insertion of segments based on silences
Create a corpus of all transcripts to search over

Allows multiple tiers to be transcribed (speakers,
gestures, comments, translations)



Why use Elan?

 Instant access to points in media via
text

* Well-known standard format that is
being adopted by online services



iINFORMATION ~ [JFILEBROWSER  [)IMAGES  [d]AUDIO/VIDEO  [@) TRANSCRIPTIONS

Recordings in South Efate

[ Multimediaitem 1 of 2 M

& DOWNLOAD MP3
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EAF TRS IXT
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Go maarik, teetwei malnen kin, mal ni nmalko, gar ruto- rupi
nafet rupi maau.

And 'maarik', long ago, when, in the time of

darkness, they were there, they were a group,
they were warriors.

Go maarlk,  teetwei  malnen  kin, mal i

go maarik teetwel malnen kin mal

and | | mister before as REL

ni

time || of

Time — aligned audio and transcript in the
PARADISEC archive



Simple Elan

Transcribe media
No speed controls
Single tier of transcription

Allows time-aligning of existing
transcript



* To begin with: make an index of what is
on a media file

— could be a summary:

« first five minutes are general conversation; next
ten minutes are singing; next ten minutes is a
story told by XXX

— could be a transcript (word by word typing

what is said on the recording)



Installation

Free download from MPI site

Version 5.7 (current at July 2019)

http://tla.mpi.nl/tools/tla-tools/elan/

SimpleElan version 1.1

Manual updated 2018-12-05


http://tla.mpi.nl/tools/tla-tools/elan/

Filetypes

Whatever your system allows:
.mov, .avi, .wmyv, .mpg
.wav, .vob, .mp3,

Annotation is stored in Elan Annotation
Format (.eaf)

— XML, schema-based format (= a good thing)



Elan Imports

ELAN - NT1-9800¢

Type Search View Options Window He

e OO0

218 Edit Annotation Tier
New... 3#EN
Open... #0
Open Recent File >
Close #’W
Save 3#S
Save As... {r38S

Save as Template... \_{
Save Selection as .eaf...
Save a Copy as EAF 2.7...

Merge Transcriptions...

#S

v

Automatic Backup >
Page Setup 3P
Print Preview 3P
Print kP
Multiple File Processing
Export As >
Export Multiple Files As >
Import >
Import Multiple Files As >

Exit

#Q

Subtitles Lexicon = Comments = Audio Rec

o raitom wa?"

sa pur.

ymi. Me nrakeskei go papa ga ifsei.

kai go ki ler mro pak esan ga itkos mai.
| go tmen ipios.

in ga ipakor wes.
ver raki elau go ki pios,"Koaisen paler”.
Koaisen paler.”

kam ntas.
Selection: 00:00:58.360 - 00:01:03.900 554
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Toolbox File...

FLEXx File...

CHAT File...

Transcriber File...

CSV / Tab-delimited Text File...
Praat TextGrid File...

Import Tiers from Recognizer...
Shoebox File...
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Elan Exports

__ELAN - NT1-98009-B.eaf _

2l Edit Annotation Tier Type

Search View Options Window Help

New. ¥N

- Subtitles = Lexicon = Comments = Audio Recognizer = Video Recognizer = Metadata = Controls |
Open... ¥0
Open Recent File > &
Close *W Begin Time | End Time Duration
kai go ki ler mro pak esan ga itkos mai. 00:01:41.980 00:01:50.660 00:00:08.680
Save #S | gotmenipios. 00:01:51.880 00:01:58.540 00:00:06.660
Save As... GRS 00:01:58.900 00:02:02.700 00:00:03.800
Save as Template... {3 Inga ipakor wes. 00:02:06.040 00:02:10.699 00:00:04.659
Save Selocligh Siadoe ver raki elau go ki pios,"Koaisen paler”. 00:02:11.179 00:02:19.279 00:00:08.100
> Koaisen paler.” 00:02:20.820 00:02:25.620 00:00:04.800
Save a Copy as EAF 2.7... kam ntas. 00:02:26.159 00:02:29.880 00:00:03.721
, 4o, Koaisen paler”. Ipan kam ntas go ipo lag ipreg nalag, 00:02:30.740 00:02:39.680 00:00:08.940
Merge Tr'anscnptlons... eno, nato wawa nato wawa meremo, koaiseno seno.((endsong)) 00:02:40.160 00:02:58.379 00:00:18.219
Automatic Backup » kam ntas, go ntas ipamau naputuwen. 00:02:58.880 00:03:05.640 00:00:06.760
Page Setup {+ 3P Selection: 00:00:58.360 - 00:01:03.900 5540
Pr!nt Preview 3P El l p1 l Pl l Pl [ [>S l g |@ ‘ ‘ - l - I 1 I T || Selection Mode | Loop Mode )
Print #EP —
Multiple File Processing ~ » |
5 "“;“““"‘I““‘““I“““"’l”“““‘I““““'I
ExportAs .l Toolbox File (UTF-8)... 00:00:59.000  00:01:00.000 00:01:02.000 | 00:01:03.000  00:01:0¢
Export Multiple Files As > FLEX File... ) rapaus kin ki,"Gag tmam go raitom wa?"
Import > CHAT File... |
Import Multiple Files As > Tab-delimited Text...
. Tiger-xml...
Exit %£Q ‘ Interlinear Text...
HTML...

Traditional Transcript Text...

Praat TextGrid...

List of Words...

SMIL

QuickTime text...
Subtitles Text...

Tiers for Recognizer...

Media Clip using M2-edit...

Media Clip using Script...

Image from ELAN Window...

Filmstrip Image...
Shoebox File...




Demo files

provided by MPI

* elan-example1.mpg
* elan-example1.wav
» elan-example1.eaf

« http://www.mpi.nl/tools/elan/elan-example.zip



http://www.mpi.nl/tools/elan/elan-example.zip

Starting Elan

New file

Select media (up to 4 media files can be
jointly annotated)

You can choose a ‘template’ that has existing
settings

Name media and annotation file the same
(e.g fileX.mpg, fileX.eaf)



Simple Elan

» Allows you to transcribe media

* Drag and drop media file onto the
opening screen =

nnnnnnnnnnnnnnnnnnnnnnnn

.......

ooooooooooooooooooooooooooooo




Simple Elan

) Simple-ELAN 1.1 - Undefined File Name

|| | transcript Font Size: 12 = %
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@ Simple-ELAN 1.1

transcript

Simple Elan

Edit
New...

Help

#EN Simple-ELAN 1.1 - NT1-20002-20002A.eaf

Open...
Close

#®0
#EW

4 FontSize:12 = @+

Save document

Save As... 0#S

Exit
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Simple Elan

ee0e

Simple-ELAN 1.1 - NT1-20002-20002A.eaf

transcript

Font Size: 12 | = | |+

1 namba 31 march 2000
00:00:00.000 - 00:00:16.060

2 Kafo gag traus apu motu nigmam
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3
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XX

Simple Elan

Simple-ELAN 1.1 - NT1-20002-20002A.eaf

transcript

% FontSize: 12
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Simple Elan

 gives you a time-aligned index of your
media

* needs no setup

* the file it creates can then be opened in
Elan



Simple Elan

000 Simple-ELAN 1.1 - Undefined File Name

transcript i4 FontSize:12 = | | %

e Video

00:00:00.000 - 00:00:05.625
2 iser totur faat

00:00:05.625 - 00:00:10.009

3 me kineu aleka ipi tenmaagwen, heu nen a sees leka
00:00:10.009 - 00:00:17.112

__00:00:17.112 - 00:02:05.013

00:00:17.112
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Elan



Use template

A set of ELAN templates for free download.
There are six templates covering the following types of requirements:

Template1.etf: 1 speaker, tiers for Text and Free Translation.
Template2.etf: 2 speakers, tiers for Text and Free Translation.

Template3.etf: 2 speakers, tiers for Text, Free Translation, and
Gesture.

Template4.etf: 1 speaker, tiers for Text, Word, Gloss, and Free
Translation.

TemplateS.etf: 2 speakers, tiers for Text, Word, Gloss, and Free
Translation.

Template6.etf: 2 speakers, tiers for Text, Word, Gloss, Free
Translation, and Gesture.

http://www.rnld.org/software



« Save your file right away: File>Save. The
ELAN file extension is .eaf.

« Set your Automatic backup to 5 minutes.
File>Automatic Backup>5 minutes.



 To add an annotation, double-click inside the
blue area. Type your annotation.

 To delete an annotation, click the annotation
so that the horizontal line is blue. Then use
Edit>Delete Annotation.



Variable playback speed

 Controls — Rate

* Loop — set a ‘chunk’ then loop over it
until you transcribe it



Elan corpus

e Search within a document
« Search over a set of Elan files

 Define a folder of files



Volume:

100

Rate:

100

00:21:44.840

4] 414 EQ| | > | Dk DE

I 00:21:43.000

Elan corpus

Grid

.

Text  Subtitles Lexicon ~ Comments Metadata

Search Domain
Specify new domain

New Domain...
New Domain from IMDI Search...

Select an existing domain

warnman
rev

elan
Efate

100

200

Define search domain

oc



Elan corpus

Grid
Volume:
100
I
0
o0 e
Annotations
Rate:

100 | Search nafsan

| ! [ regular expression

0

.21 Nr File Tier
00:21:44.840 71z @unkno...
4| 4|14 | B4 ‘N » M* l’i 18 124 te@unkno...
19 124 mr@unkn....
20 124 mr@unkn....
USRS 54 194 wordtimes tx@unkno...
AV P 22 124 wordtimes tx@unkno...
I ooy 23 124.wordtimes mr@unkn...
24 124 wordtimes mr@unkn._..

Tier-0 25 NT1-004-004A Tier-0

e 26 NT1-004-004A Tier-0

27 NT1-004-004A Tier-0
28 NT1-004-004A Tier-0
29 NT1-004-004A Tier-0
30 NT1-004-004B Tier-0
31 NT1-004-004B Tier-0
32 NT1-004-004B Tier-0
33 NT1-005-005A Tier-0
34 NT1-005-005A Tier-0
35 NT1-005-005A Tier-0
36 NT1-005-005A Tier-0
37 NT1-005-005A Tier-0
38 NT1-005-005A Tier-0

»

Text  Subtitles Lexicon Comments Metadata

Before

Avyuwantem...
Tafra, akam...
Yes, yu want...
Maarik go mt...
ina ito kai wi...
Selwan ratori...

Utu Tangoa,...
Tafra ruk fam....
Selwan Pase...
Amurin nag k...

13 secs
igat defren...

Search eaf files

Search

case sensitive

Defi
Expa

41 occurrences in 38 annotations in 106 files (7.264 seconds) |

Annotation

nafsan

nafsan

nafsan

nafsan

nafsan

nafsan

nafsan

nafsan

Ale, ok selwan kin nkas ilaotu,
Naik seserik ru mai fam pan pan
Wan taem, mi mi stap long
Mtulep itapes mau me ipnut to.
Nafsan matu ni tiaui. ltok kai wes
Me itap metpaakor nafsan nig

.. Nlaken wak ikano tae nafsan nen

Namba 27, aliat fraide, go nafsan
Disemba namba 2, Efil, aliat tap,
Selwan Paser Kalagis inrog
Atae nag kefo nrik mam ki napet
Go malfanen kafotli aflatilsaki me
N: Me itap metpaakor nafsan nig
K) Yu save igat defren, wanem

After Parent

ipak

skei

i=

skei

ipak

skei

i=

skei
Rusos...
Yufala...
Orkaf...
Faat...
Mai nai...
Itok rik...
Inrog t...
Namba...
NT:Be...
Atae...
Itili nag...
Selwa...
K:read...
NT: Ku...

Y
100

|
200
e R R R R
T | o
00:21:52.000 00:21:53.000 oC




Quick segmentation

® OO0 ELAN - NT1-98009-B.eaf

File Edit Annotation Tier Type Search Viewmwmdow Help

Propagate Time Changes

Annotation Mode
- Media Synchronization Mode
(*) One keystroke per annotation (adjacent annotations) Transcription Mode

v Segmentation Mode

AA
\/

Interlinearization Mode

() Two keystrokes per annotation (non-adjacent annota

() One keystroke per annotation, fixed duration

Duration (ms.) 1000
Activity Monitoring

Web Services

Stroke marks end of annotation

() One keystroke per annotation, press to mark start, re  Play Around Selection...

| Delayed mode: compensate for keystroke delay (ms.) Rate and Volume Toggle...

Set Frame Length

Segmentation Key: <’ Language
Language for multilingual content

v

00:00:55.050 Selection: 00:00:58.360 - 00:01:03.900 5540

M M E v e DEM ] [Ps[5 k] Daje <




Quick segmentation

® OO0 ELAN - NT1-98009-B.eaf

File Edit Annotation Tier Type Search View Options Window Help

W Controls |

() Two keystrokes per annotation (non-adjacent annotations)
(¢) One keystroke per annotation (adjacent annotations)
() One keystroke per annotation, fixed duration
Duration (ms.) 1000
() One keystroke per annotation, press to mark start, release to mark end

| Delayed mode: compensate for keystroke delay (ms.)

Segmentation Key: </

00:00:55.050 Selection: 00:00:58.360 - 00:01:03.900 5540

MMM T e DI PsTs k] Daj# @

——



Quick segmentation

* This results in an Elan file that has
chunks or segments ready to be typed

Into
« Saves lots of time
» Set ‘loop’ then enter transcript



Transcription mode

e OO0 ELAN - NT10-WO07-B.eaf
File Edit A Tier Type Search View Options Window Help
00:00:35.225 No Typel : UtteranceType
IR EE (M Loop Mode -
Time Interval: 00:00:31.810 - 00:00:35.225 | Toggle Loop mbdﬁm)
0:00:32000  00:00:34.000 10
+ : 11
- 12
13
Volume 100
{ ) 14
Rate 100 15
’ 16
Settings
17
Q] Automatic playback of media 18
@] Create missing annotations
L?] Show tier names 19
20
Navigate across column 21
L?] Scroll current annotation to center
Configure... 22
23




Audio recognizer

Silence Analyzer
« Chunks the media according to ‘silence’
* You can determine what silence is and how long it should be

e OO ELAN - Undefined File Name

File Edit Annotation Tier Type Search View Options Window Help

| Grid = Text Subtitles Lexicon = Comments Video Recognizer = Metadata = Controls |

Recognizer: | Silence Recognizer MPI-PL
Parameters _lext-to-Speech alignment
v Silence Recognizer MPI-PL
Files List: |  BAS - WebMAUS Basic
Fine audio segmentation for splitting audio into utterance level segments.
Silence Le]  Recognizer for detecting longer segments with a lower amplitude than a given treshold
() Select IAIS 09 Keyword spotter that finds similar portions to an example from the current file
- Speaker diarization pipeline: Segment audio, find speech segments, group segments of the same speakers

4»
| _—

Selection
- Speaker analysis component to diarize an unknown number of speakers in a single audio file

(o) selection [ Jtier file T
Selections

| 4= Channell || 4= Channel2 |

=) (®) (@) (%) (@



Elan sources of information

“Using Elan” (Albert Bickford)
Elan Manual (Birgit Hellwig et al)
Andrea Berez's course on Elan
Elan mailing list

ColLang courses



